hpctoolkit

[ Home | Overview | Publications ] • [ Examples ] • [ Software/Downloads | Documentation/Questions ] • [ People | Acks ]


Current Spack Issues for HPCToolkit

Table of Contents

1 Introduction

Spack is a moving target and receives multiple commits per day. Normally, HPCToolkit will build and run successfully with the latest version of all of its prerequisite packages, but sometimes not. This page covers the current known issues where HPCToolkit fails to build with the latest version of spack. The main build directions are at:

software-instructions.html

Report problems to hpctoolkit-forum at rice dot edu. But before reporting a problem, first try the versions recommended in the packages.yaml file in the spack subdirectory of the hpctoolkit repository. And always check the latest version of this file on the hpctoolkit web site.

http://hpctoolkit.org/spack-issues.html

Last revised: September 11, 2020.

2 Current Issues

2.1 (2020-09-05) Configure warns about -fPIC.

As of commit b2d3d067ecad on 2020-09-05, the master branch now wants libunwind and xz (lzma) to be built with variant +pic. This is used to workaround a deadlock with hpcrun, openmpi 4.x and UCX. If not, then you’ll see this warning at the bottom of configure.

WARNING: The following prereqs are missing an archive (.a) compiled with -fPIC.
WARNING:    libunwind lzma
WARNING: 
WARNING: hpcrun is unable to properly hide these libraries from the
WARNING: application and this may cause deadlock or segfault.
WARNING: Recompile the above libraries with -fPIC (+pic in spack).

For now, this is only a warning. Everything will work as before, you just won’t get the benefit of the work around. But going forward, you should build libunwind and xz with variant +pic. For example, in packages.yaml.

libunwind:
  version:  [1.4.0]
  variants: +xz +pic
xz:
  version:  [5.2.5]
  variants: +pic

3 Recently Resolved Issues

3.1 (2020-06-29) Cray front-end compilers

Spack compiler find was previously broken for detecting the front-end compilers on Cray that HPCToolkit uses.

Fixed: This is now fixed in commit 789d060ff61b on 2020-06-29.

Note: Remember, you still need to fill in the modules: field with the following four modules. For example, this is an entry for the gcc/8.3.0 module on theta at ANL. Note that the front-end operating_system is something like sles15 (not cnl6), and the front-end target is x86_64 (not mic_knl). Your versions may differ.

- compiler:
    environment: {}
    flags: {}
    modules:
    - PrgEnv-gnu/6.0.7
    - gcc/8.3.0
    - craype/2.6.5
    - cray-mpich/7.7.14
    operating_system: sles15
    paths:
      cc:  /opt/gcc/8.3.0/bin/gcc
      cxx: /opt/gcc/8.3.0/bin/g++
      f77: /opt/gcc/8.3.0/bin/gfortran
      fc:  /opt/gcc/8.3.0/bin/gfortran
    spec: gcc@8.3.0
    target: x86_64

4 General Problems

These are general problems that arise from time to time.

4.1 Unable to fetch

Sometimes spack fails to download the source file(s) for some package and dies with a message similar to this.

==> Fetching from https://ftpmirror.gnu.org/m4/m4-1.4.18.tar.gz failed.
==> Error: FetchError: All fetchers failed for m4-1.4.18-vorbvkcjfac43b7vuswsvnm6xe7w7or5

This problem is usually temporary and the solution is to either wait a few minutes or an hour and try again, or else download the file manually and put it into a spack mirror.

4.2 Connection timeout

Another way fetch can fail is with a connection timeout. Some sites, especially sourceforge are often slow to connect. If this happens, then increase the connection timeout in config.yaml to 30 or 60 seconds (default is 10 seconds).

4.3 New version breaks the build

Sometimes the latest version of some package breaks the build. This has happened a couple of times where a new version of Boost has broken the build for Dyninst. The solution is to revert the package to an earlier version until the rest of the code catches up.

4.4 Spack core breaks the build

Sometimes but rarely, something in the spack core will change or break the code in some package.py file. The solution is to look through the spack git log and revert the repository to a recent commit before the breakage.

5 Long Term Issues

5.1 Boost 1.68.0

Avoid boost version 1.68.0, it breaks the build for hpctoolkit. Version 1.70.0 works with the latest version of dyninst (10.1.0), or else 1.66.0 is good and works with all versions of dyninst.

5.2 Elfutils 0.176

Elfutils 0.176 requires glibc 2.16 or later (for aligned_alloc) and won’t work with an older glibc, including RedHat or CentOS 6.x and Blue Gene. On systems with an old glibc, use version 0.175.

5.3 IBM-Java fails to fetch (powerpc)

IBM is fairly aggressive about taking down old versions, so you may find that fetching ibm-java fails while trying to install hpcviewer (powerpc only).

==> Installing ibm-java
==> No binary for ibm-java found: installing from source
==> Error: FetchError: All fetchers failed

If this happens, first compare spack info ibm-java with what versions are available at IBM’s download site. If there is another 8.0.x.y version that spack understands that is still available for download, then use that.

http://public.dhe.ibm.com/ibmdl/export/pub/systems/cloud/runtimes/java

If not, then manually download the latest 8.0.x.y version, compute a sha256sum checksum for the file and then edit the ibm-java/package.py file to add this version. And then report the problem to the spack maintainer.



©2000-2020 Rice UniversityRice Computer Science